WJCT Public Media - Donation Processing Issue Affecting WJCT Services – Incident details

All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

Donation Processing Issue Affecting WJCT Services

Resolved
Partial outage
Started 22 days agoLasted about 21 hours

Affected

Websites

Partial outage from 8:36 PM to 5:51 PM

wjct.org

Partial outage from 8:36 PM to 5:51 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience.

  • Investigating
    Investigating

    We are currently investigating an issue affecting several WJCT services, which may cause difficulties when making a donation. Our team is working to resolve the problem as quickly as possible. Please check back here for updates or call 904.353.9528. We are sorry for the inconvenience.