All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

wjct.org is currently down and unavailable

Resolved
Operational
Started about 1 year ago Lasted 4 days

Affected

Websites
jaxpbs.org
jaxmusic.org
wjct.org
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    The issues with wjct.org has been resolved and the website is now being monitored for any further problems. Thank you for your patience and understanding.

  • Investigating
    Investigating

    We apologize for the inconvenience and are working to resolve the issue as soon as possible. Please check back later for updates. Thank you for your patience.

  • Monitoring
    Monitoring

    The issue with wjct.org has been resolved and the website is now being monitored for any further problems. Thank you for your patience and understanding.

  • Investigating
    Investigating

    We apologize for the inconvenience and are working to resolve the issue as soon as possible. Please check back later for updates. Thank you for your patience.