All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

We are currently experiencing an interruption in our phone service.

Resolved
Operational
Started 10 months ago Lasted about 4 hours

Affected

100 Festival Park Ave
Updates
  • Resolved
    Resolved

    This incident has been resolved. Thanks for your patience.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We apologize for the inconvenience, but our phone lines are currently experiencing technical difficulties. If you need to contact us, please email us donate@wjct.org. We appreciate your patience and understanding.