All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

wjct.org is currently down

Resolved
Operational
Started 10 months ago Lasted 44 minutes

Affected

Websites
jaxpbs.org
jaxmusic.org
wjct.org
Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you again for your patience while this was resolved.

  • Identified
    Identified

    We are continuing to work on a fix for this incident. Thank you again for your patience as we work to resolve the issue.

  • Investigating
    Investigating

    We are currently investigating this incident. Thank you for your patience.