All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

Now Playing Information Incorrect on Digital Radio Streams

Resolved
Operational
Started about 2 months ago Lasted about 5 hours

Affected

Digital Audio Streams
WJCT News 89.9
WJCT Classical 24© 89.9 HD2
WJCT The Independent 89.9 HD4
WJCT Anthology 89.9 HD3
WJCT Radio Reading Service
Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience and understanding.

  • Investigating
    Investigating

    We're currently experiencing technical difficulties with our Now Playing information across all digital radio streams. This issue is due to the recent time change. Our team is actively working on a solution. Thank you for your patience and understanding.