All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

Completed
FM Transmitter Maintenance

Status
Resolved after 30 minutes
Started
July 11, 2022 at 4:00 AM
Completed
July 11, 2022 at 4:30 AM
Affects
Anthology 89.9 HD3
Classical 24© 89.9 HD2
Electro Lounge Radio 89.9 HD4
WJCT News 89.9
WJCT Radio Reading Service
  • Completed
    July 11, 2022 at 4:30 AM

    Maintenance has completed successfully

  • Update
    July 11, 2022 at 4:00 AM

    Maintenance is now in progress

  • Update
    July 11, 2022 at 4:00 AM

    Maintenance is now in progress

  • Update
    July 11, 2022 at 4:00 AM

    Maintenance is now in progress

  • In progress
    July 11, 2022 at 4:00 AM

    Maintenance is now in progress

  • Planned
    July 11, 2022 at 4:00 AM

    Maintenance is being completed on the WJCT Public Media FM radio broadcast tower on Monday, July 11, 2022, starting at 12 a.m. The FM transmitter will be off during this time. The maintenance is expected to last about 30 minutes.

    During that time, our radio service will continue to be available via streaming on the web, on the WJCT Public Media app or via smart speakers (i.e. Amazon Alexa or Google Home). Thank you for your patience while this work is completed.