All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

Resolved
Technical difficulties on Jax PBS affecting programming

Started
July 09, 2022 at 4:15 PM
Status
Resolved after 6 days

Impact

Degraded performance
Affected
Digital Video Streams
Jax PBS
Television Channels
Jax PBS
Jax PBS More!
  • Resolved
    July 15, 2022 at 9:01 PM

    We have implemented a fix, and we are monitoring the results. Thank you for your patience as we worked to resolve this issue.

  • Investigating
    July 09, 2022 at 4:15 PM

    Jax PBS is experiencing technical difficulties. These difficulties may affect our regularly scheduled programming. Our technicians are working to resolve these issues. We appreciate your patience and apologize for any inconvenience.