All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

Temporary Interruption of WJCT Digital Audio Streams

Completed
Scheduled for February 08, 2024 at 5:01 AM – 5:31 AM

Affects

Digital Audio Streams
WJCT News 89.9
WJCT Classical 24© 89.9 HD2
WJCT The Independent 89.9 HD4
WJCT Anthology 89.9 HD3
WJCT Radio Reading Service
Updates
  • Completed
    February 08, 2024 at 5:31 AM
    Completed
    February 08, 2024 at 5:31 AM

    Maintenance has completed successfully

  • In progress
    February 08, 2024 at 5:01 AM
    In progress
    February 08, 2024 at 5:01 AM

    Maintenance is now in progress

  • Planned
    February 08, 2024 at 5:01 AM
    Planned
    February 08, 2024 at 5:01 AM

    Our digital audio streams will be temporarily unavailable starting at 12:01 a.m. Thursday due to regular scheduled maintenance. We apologize for any inconvenience this may cause and appreciate your understanding as we work to enhance your listening experience.