All systems operational

This web page shows the status of WJCT Public Media services across all television channels, radio stations, websites, digital audio streaming and apps. Upcoming maintenance and any known issues will be published here.

To report an issue or outage that is not listed below, please contact WJCT Audience Services at audienceservices@wjct.org or 904-358-6360.

Technical Difficulties with Jax PBS Digital Stream

Resolved
Operational
Started 2 months ago Lasted 5 days

Affected

Digital Video Streams
Jax PBS
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently experiencing technical difficulties with our Jax PBS digital stream. Viewers may notice a different schedule of programming online than what is being broadcast. Both the Jax PBS and PBS teams are aware of the issue and are working diligently to resolve it. We apologize for any inconvenience this may cause and thank you for your patience and understanding. Stay tuned for updates.